Audio & Video Calling Performance
Incident Report for
Samepage.io
Resolved
This incident has been resolved.
Posted
Apr
04
,
2019
-
23:55
UTC
Monitoring
Some users may have experienced delays in audio or video calls. The issue has been addressed and we are continuing to monitor performance.
Posted
Apr
04
,
2019
-
19:20
UTC
This incident affected: Samepage App.
×
Subscribe to Incident
Subscribe to updates for
Audio & Video Calling Performance
via . You'll receive .